[Mac][Ruby]Rails環境構築には、SQLiteを使うためのgemが必要!

 

 

なんと!9本の記事で詳しく丁寧に解説してるのだ!

 

こんにちは。ナガオカ(@boot_kt)です。

 

9本の記事でRails環境構築の解説をしています

この記事は8本目、SQLiteを使うためのgemのインストールについて解説してます

 

この記事のザックリした内容
◆対象読者

  • Railsの環境構築手順を知りたい人
  • Railsの環境構築で、なぜそれらをインストールするのか「理解」したい人
  • Homebrew?、rbenv?、Bundeler?、gem? ←これらの事がよく分からない人
  • オススメしません!! → 手っ取り早くRails環境構築手順を知りたい人

 

 

 

 

事前説明

ここではこれをインストールします

RubyでSQLiteを使うためのgem

 

Rubyをインストールした

SQLiteをインストールした

 

しかし、

 

だからと言ってすぐにRubyのプログラムの中からSQLiteを使えると思うなよ!!!!!!

 

RubyからSQLiteを使うにはそれ用のgemが必要なのだっ!!!

 

gemってなに?
ぐだぐだ説明しても分かりにくいので、プラグインみたいなものと思ってていいんじゃないかな

 

事前確認

SQLite用のgemがインストールされているか確認する

> gem list sqlite

*** LOCAL GEMS ***

sqlite3-ruby (1.3.3)

こんな感じでsqlite3-rubyがあればインストール済み
出てこなければまだなのでこれからインストールしましょう

 

インストール

特に難しい手順は無いです。

このコマンド打つだけ

 

広告




 

 


 

Rubyプログラミングのレッスンに興味がある方、レッスン内容を聞いてみたい方、なんなりとお問い合わせください。
無料体験レッスンもありますのでお気軽にどうぞ!!!

 

 

 

参考書籍

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

ABOUTこの記事をかいた人

Windows/Mac/Linuxを使う現役システムエンジニア&プログラマ。オープン系・組み込み系・制御系・Webシステム系と幅広い案件に携わる。C言語やC#やJava等数多くのコンパイラ言語を経験したが、少し飽きてきたので、最近はRubyやPython、WordPressなどのWeb系を修得中。初心者向けのプログラミング教室も運営中。オンライン・対面・出張等でプログラミングをレッスンします。